// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d){1,2}\/(\d){1,2}\/(\d){1,4}\s(\d){1,2}:(\d){1,2}:(\d){1,2}\.(\d){1,8}\s\[(?<host>.*?)\]\sTook\s+(?<NumSources>\d+)\s+sources\s+(?<seconds>(\d+\.\d+|\d+))\s+seconds\sto\scollect\s(?<numlogs>\d+)\s+logs\s+\-\s+avg\s(?<avg>(\d+\.\d+|\d+)).*?$").unwrap();
let string = "09/29/2019 00:00:01.989966 [CHR2PR2SC62] Took 0 sources 0.0000 seconds to collect 0 logs - avg 0.00 logs/sec
09/29/2019 01:51:42.517856 [CHR2PR2SC62] Took 1 sources 1.1326 seconds to collect 8000 logs - avg 7063.51 logs/sec
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}