const regex = /^(\d){1,2}\/(\d){1,2}\/(\d){1,4}\s(\d){1,2}:(\d){1,2}:(\d){1,2}\.(\d){1,8}\s\[(?<host>.*?)\]\sTook\s+(?<NumSources>\d+)\s+sources\s+(?<seconds>(\d+\.\d+|\d+))\s+seconds\sto\scollect\s(?<numlogs>\d+)\s+logs\s+\-\s+avg\s(?<avg>(\d+\.\d+|\d+)).*?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d){1,2}\\\/(\\d){1,2}\\\/(\\d){1,4}\\s(\\d){1,2}:(\\d){1,2}:(\\d){1,2}\\.(\\d){1,8}\\s\\[(?<host>.*?)\\]\\sTook\\s+(?<NumSources>\\d+)\\s+sources\\s+(?<seconds>(\\d+\\.\\d+|\\d+))\\s+seconds\\sto\\scollect\\s(?<numlogs>\\d+)\\s+logs\\s+\\-\\s+avg\\s(?<avg>(\\d+\\.\\d+|\\d+)).*?$', 'gm')
const str = `09/29/2019 00:00:01.989966 [CHR2PR2SC62] Took 0 sources 0.0000 seconds to collect 0 logs - avg 0.00 logs/sec
09/29/2019 01:51:42.517856 [CHR2PR2SC62] Took 1 sources 1.1326 seconds to collect 8000 logs - avg 7063.51 logs/sec
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}