# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(['"])((?:(?!\1|\\).|\\.)*)\1/Subbed/gsx;t' <<< "Hello Colm \"This is a test\\\\\"
\"This is also an NL test\"
'And this has an escaped quote don\'t in it ' Blue Boy
\"This has a single quote ' but doesn\' end the quote as it started with double quotes\"
\"line spanning with escaped quote at the end of a line\\"
\"
\"Foo Bar\" \"Another Value\" something else
\"2005014523\",\"34.95661\",\"-96.74025\",\"1\",\"52\",\"52\",\"5/17/2020 - 11:10 AM\",\"By 5/17/2020 2:38 PM\",\"5/17/2020 - 12:50 PM\",\"UNPLANNED\"
Empty? \"\" Empty, line spanning \"
\" "