#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?sx)(['"])((?:(?!\1|\\).|\\.)*)\1"
Local $sString = "Hello Colm "This is a test\\\\"" & @CRLF & _
""This is also an NL test"" & @CRLF & _
"'And this has an escaped quote don\'t in it ' Blue Boy" & @CRLF & _
""This has a single quote ' but doesn\' end the quote as it started with double quotes"" & @CRLF & _
"" & @CRLF & _
""line spanning with escaped quote at the end of a line\"" & @CRLF & _
""" & @CRLF & _
"" & @CRLF & _
""Foo Bar" "Another Value" something else" & @CRLF & _
"" & @CRLF & _
""2005014523","34.95661","-96.74025","1","52","52","5/17/2020 - 11:10 AM","By 5/17/2020 2:38 PM","5/17/2020 - 12:50 PM","UNPLANNED"" & @CRLF & _
"" & @CRLF & _
"Empty? "" Empty, line spanning "" & @CRLF & _
"" "
Local $sSubst = "Subbed"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)