use strict;
my $str = 'Hello Colm "This is a test\\\\\\\\"
"This is also an NL test"
\'And this has an escaped quote don\\\'t in it \' Blue Boy
"This has a single quote \' but doesn\\\' end the quote as it started with double quotes"
"line spanning with escaped quote at the end of a line\\"
"
"Foo Bar" "Another Value" something else
"2005014523","34.95661","-96.74025","1","52","52","5/17/2020 - 11:10 AM","By 5/17/2020 2:38 PM","5/17/2020 - 12:50 PM","UNPLANNED"
Empty? "" Empty, line spanning "
" ';
my $regex = qr/(['"])((?:(?!\1|\\).|\\.)*)\1/sxp;
my $subst = 'Subbed';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";