#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[QBNRP ]*K[QBNRP ]*$)[KQBNRP ]{16}$"
Local $sString = "QBNRPQBNRPKQBNRP" & @CRLF & _
"KQBNRPQBNRPQBNRP" & @CRLF & _
" KBNRPQBNRPQB RP" & @CRLF & _
"" & @CRLF & _
"KQBNRPQBKRPQBNRP" & @CRLF & _
"KQBNRPKQBNRPKQBNRP"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")