re = /^(?=[QBNRP ]*K[QBNRP ]*$)[KQBNRP ]{16}$/m
str = 'QBNRPQBNRPKQBNRP
KQBNRPQBNRPQBNRP
KBNRPQBNRPQB RP
KQBNRPQBKRPQBNRP
KQBNRPKQBNRPKQBNRP'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end