using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[QBNRP ]*K[QBNRP ]*$)[KQBNRP ]{16}$";
string input = @"QBNRPQBNRPKQBNRP
KQBNRPQBNRPQBNRP
KBNRPQBNRPQB RP
KQBNRPQBKRPQBNRP
KQBNRPKQBNRPKQBNRP";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}