$re = '/^(?=[QBNRP ]*K[QBNRP ]*$)[KQBNRP ]{16}$/m';
$str = 'QBNRPQBNRPKQBNRP
KQBNRPQBNRPQBNRP
KBNRPQBNRPQB RP
KQBNRPQBKRPQBNRP
KQBNRPKQBNRPKQBNRP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);