import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!(.).*\\1)(?:[A2345]{5}|[23456]{5}|[34567]{5}|[45678]{5}|[56789]{5}|[6789T]{5}|[789TJ]{5}|[89TJQ]{5}|[9TJQK]{5}|[TJQKA]{5})";
final String string = "A2345\n"
+ "23456\n"
+ "34567\n"
+ "45678\n"
+ "56789\n"
+ "6789T\n"
+ "789TJ\n"
+ "89TJQ\n"
+ "9TJQK\n"
+ "TJQKA\n"
+ "52634\n"
+ "JQ89T\n"
+ "JQ89J";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}