import re
regex = re.compile(r"(?!(.).*\1)(?:[A2345]{5}|[23456]{5}|[34567]{5}|[45678]{5}|[56789]{5}|[6789T]{5}|[789TJ]{5}|[89TJQ]{5}|[9TJQK]{5}|[TJQKA]{5})", flags=re.MULTILINE)
test_str = ("A2345\n"
"23456\n"
"34567\n"
"45678\n"
"56789\n"
"6789T\n"
"789TJ\n"
"89TJQ\n"
"9TJQK\n"
"TJQKA\n"
"52634\n"
"JQ89T\n"
"JQ89J")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)