$re = '/(?!(.).*\1)(?:[A2345]{5}|[23456]{5}|[34567]{5}|[45678]{5}|[56789]{5}|[6789T]{5}|[789TJ]{5}|[89TJQ]{5}|[9TJQK]{5}|[TJQKA]{5})/m';
$str = 'A2345
23456
34567
45678
56789
6789T
789TJ
89TJQ
9TJQK
TJQKA
52634
JQ89T
JQ89J';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;