package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.)`)
var str = `Обход автозамены текста.`
var substitution = "\x{180C}$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}