$re = '/(.)/m';
$str = 'Обход автозамены текста.';
$subst = "\x{180C}$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;