use strict;
my $str = 'Обход автозамены текста.';
my $regex = qr/(.)/mp;
my $subst = '\\x{180C}$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";