const regex = new RegExp('\\.\\w+-\\w+(?=\\h)', 'gm')
const str = `.carousel-fade .carousel-item-next.carousel-item-left, .carousel-fade .carousel-item-prev.carousel-item-right, .carousel-fade .carousel-item.active {
opacity: 1
}`;
const subst = `#elements $0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);