import Foundation
let pattern = #"\.\w+-\w+(?=\h)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.carousel-fade .carousel-item-next.carousel-item-left, .carousel-fade .carousel-item-prev.carousel-item-right, .carousel-fade .carousel-item.active {
opacity: 1
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"#elements $0"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)