use strict;
my $str = '.carousel-fade .carousel-item-next.carousel-item-left, .carousel-fade .carousel-item-prev.carousel-item-right, .carousel-fade .carousel-item.active {
opacity: 1
}';
my $regex = qr~\.\w+-\w+(?=\h)~mp;
my $subst = '#elements $0';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";