$re = '~\.\w+-\w+(?=\h)~m';
$str = '.carousel-fade .carousel-item-next.carousel-item-left, .carousel-fade .carousel-item-prev.carousel-item-right, .carousel-fade .carousel-item.active {
opacity: 1
}';
$subst = "#elements $0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;