import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)(?<!\\d[,.])(?:\\d{1,3}(?:[. \\xA0]\\d{3})*|\\d+)(?:,\\d+)?(?![.,]?\\d)";
final String string = "120.000,00\n"
+ "120 000,00\n"
+ "40 000\n"
+ "456.667\n"
+ "334532\n"
+ "123 223 333,345555";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}