use strict;
my $str = '120.000,00
120 000,00
40 000
456.667
334532
123 223 333,345555';
my $regex = qr/(?<!\d)(?<!\d[,.])(?:\d{1,3}(?:[. \xA0]\d{3})*|\d+)(?:,\d+)?(?![.,]?\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}