$re = '/(?<!\d)(?<!\d[,.])(?:\d{1,3}(?:[. \xA0]\d{3})*|\d+)(?:,\d+)?(?![.,]?\d)/m';
$str = '120.000,00
120 000,00
40 000
456.667
334532
123 223 333,345555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);