const regex = /(?<!\d)(?<!\d[,.])(?:\d{1,3}(?:[. \xA0]\d{3})*|\d+)(?:,\d+)?(?![.,]?\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)(?<!\\d[,.])(?:\\d{1,3}(?:[. \\xA0]\\d{3})*|\\d+)(?:,\\d+)?(?![.,]?\\d)', 'gm')
const str = `120.000,00
120 000,00
40 000
456.667
334532
123 223 333,345555`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}