#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z]{3} +[A-Za-z]{3} +(?:[1-9]|[12]\d|3[01]) +(?:[01]\d|2[0-3]):[0-5]\d:[0-5]\d +(?:19|20)\d{2}\b"
Local $sString = "Thu Oct 1 23:01:00 2020 +00:00" & @CRLF & _
"LENGTH : '275'" & @CRLF & _
"ACTION :[7] 'CONNECT'" & @CRLF & _
"DATABASE USER:[1] '/'" & @CRLF & _
"PRIVILEGE :[6] 'SYSDBA'" & @CRLF & _
"CLIENT USER:[9] 'test_user'" & @CRLF & _
"CLIENT TERMINAL:[5] 'pts/0'" & @CRLF & _
"STATUS:[1] '0'" & @CRLF & _
"DBID:[10] '1762369616'" & @CRLF & _
"SESSIONID:[10] '4294967295'" & @CRLF & _
"USERHOST:[21] 'testdevserver'" & @CRLF & _
"CLIENT ADDRESS:[0] ''" & @CRLF & _
"ACTION NUMBER:[3] '100'" & @CRLF & _
"" & @CRLF & _
"Thu Oct 1 23:01:00 2020 +00:00" & @CRLF & _
"LENGTH : '296'" & @CRLF & _
"ACTION :[29] 'SELECT STATUS FROM V$INSTANCE'" & @CRLF & _
"DATABASE USER:[1] '/'" & @CRLF & _
"PRIVILEGE :[6] 'SYSDBA'" & @CRLF & _
"CLIENT USER:[9] 'test_user'" & @CRLF & _
"CLIENT TERMINAL:[5] 'pts/0'" & @CRLF & _
"STATUS:[1] '0'" & @CRLF & _
"DBID:[10] '1762369616'" & @CRLF & _
"SESSIONID:[10] '4294967295'" & @CRLF & _
"USERHOST:[21] 'testdevserver'" & @CRLF & _
"CLIENT ADDRESS:[0] ''" & @CRLF & _
"ACTION NUMBER:[1] '3'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")