import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z]{3} +[A-Za-z]{3} +(?:[1-9]|[12]\\d|3[01]) +(?:[01]\\d|2[0-3]):[0-5]\\d:[0-5]\\d +(?:19|20)\\d{2}\\b";
final String string = "Thu Oct 1 23:01:00 2020 +00:00\n"
+ "LENGTH : '275'\n"
+ "ACTION :[7] 'CONNECT'\n"
+ "DATABASE USER:[1] '/'\n"
+ "PRIVILEGE :[6] 'SYSDBA'\n"
+ "CLIENT USER:[9] 'test_user'\n"
+ "CLIENT TERMINAL:[5] 'pts/0'\n"
+ "STATUS:[1] '0'\n"
+ "DBID:[10] '1762369616'\n"
+ "SESSIONID:[10] '4294967295'\n"
+ "USERHOST:[21] 'testdevserver'\n"
+ "CLIENT ADDRESS:[0] ''\n"
+ "ACTION NUMBER:[3] '100'\n\n"
+ "Thu Oct 1 23:01:00 2020 +00:00\n"
+ "LENGTH : '296'\n"
+ "ACTION :[29] 'SELECT STATUS FROM V$INSTANCE'\n"
+ "DATABASE USER:[1] '/'\n"
+ "PRIVILEGE :[6] 'SYSDBA'\n"
+ "CLIENT USER:[9] 'test_user'\n"
+ "CLIENT TERMINAL:[5] 'pts/0'\n"
+ "STATUS:[1] '0'\n"
+ "DBID:[10] '1762369616'\n"
+ "SESSIONID:[10] '4294967295'\n"
+ "USERHOST:[21] 'testdevserver'\n"
+ "CLIENT ADDRESS:[0] ''\n"
+ "ACTION NUMBER:[1] '3'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}