use strict;
my $str = 'Thu Oct 1 23:01:00 2020 +00:00
LENGTH : \'275\'
ACTION :[7] \'CONNECT\'
DATABASE USER:[1] \'/\'
PRIVILEGE :[6] \'SYSDBA\'
CLIENT USER:[9] \'test_user\'
CLIENT TERMINAL:[5] \'pts/0\'
STATUS:[1] \'0\'
DBID:[10] \'1762369616\'
SESSIONID:[10] \'4294967295\'
USERHOST:[21] \'testdevserver\'
CLIENT ADDRESS:[0] \'\'
ACTION NUMBER:[3] \'100\'
Thu Oct 1 23:01:00 2020 +00:00
LENGTH : \'296\'
ACTION :[29] \'SELECT STATUS FROM V$INSTANCE\'
DATABASE USER:[1] \'/\'
PRIVILEGE :[6] \'SYSDBA\'
CLIENT USER:[9] \'test_user\'
CLIENT TERMINAL:[5] \'pts/0\'
STATUS:[1] \'0\'
DBID:[10] \'1762369616\'
SESSIONID:[10] \'4294967295\'
USERHOST:[21] \'testdevserver\'
CLIENT ADDRESS:[0] \'\'
ACTION NUMBER:[1] \'3\'';
my $regex = qr/^[A-Za-z]{3} +[A-Za-z]{3} +(?:[1-9]|[12]\d|3[01]) +(?:[01]\d|2[0-3]):[0-5]\d:[0-5]\d +(?:19|20)\d{2}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}