# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-Za-z]{3} +[A-Za-z]{3} +(?:[1-9]|[12]\d|3[01]) +(?:[01]\d|2[0-3]):[0-5]\d:[0-5]\d +(?:19|20)\d{2}\b"
test_str = ("Thu Oct 1 23:01:00 2020 +00:00\n"
"LENGTH : '275'\n"
"ACTION :[7] 'CONNECT'\n"
"DATABASE USER:[1] '/'\n"
"PRIVILEGE :[6] 'SYSDBA'\n"
"CLIENT USER:[9] 'test_user'\n"
"CLIENT TERMINAL:[5] 'pts/0'\n"
"STATUS:[1] '0'\n"
"DBID:[10] '1762369616'\n"
"SESSIONID:[10] '4294967295'\n"
"USERHOST:[21] 'testdevserver'\n"
"CLIENT ADDRESS:[0] ''\n"
"ACTION NUMBER:[3] '100'\n\n"
"Thu Oct 1 23:01:00 2020 +00:00\n"
"LENGTH : '296'\n"
"ACTION :[29] 'SELECT STATUS FROM V$INSTANCE'\n"
"DATABASE USER:[1] '/'\n"
"PRIVILEGE :[6] 'SYSDBA'\n"
"CLIENT USER:[9] 'test_user'\n"
"CLIENT TERMINAL:[5] 'pts/0'\n"
"STATUS:[1] '0'\n"
"DBID:[10] '1762369616'\n"
"SESSIONID:[10] '4294967295'\n"
"USERHOST:[21] 'testdevserver'\n"
"CLIENT ADDRESS:[0] ''\n"
"ACTION NUMBER:[1] '3'")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.