#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-Z]+(_?([a-zA-Z]+|[0-9]+))*'*"
Local $sString = "m" & @CRLF & _
"a_4" & @CRLF & _
"in23_left" & @CRLF & _
"a1b2_3'" & @CRLF & _
"camelCase" & @CRLF & _
"x''"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")