import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]+(_?([a-zA-Z]+|[0-9]+))*'*";
final String string = "m\n"
+ "a_4\n"
+ "in23_left\n"
+ "a1b2_3'\n"
+ "camelCase\n"
+ "x''";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}