$re = '/[a-zA-Z]+(_?([a-zA-Z]+|[0-9]+))*\'*/';
$str = 'm
a_4
in23_left
a1b2_3\'
camelCase
x\'\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);