const regex = /[a-zA-Z]+(_?([a-zA-Z]+|[0-9]+))*'*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z]+(_?([a-zA-Z]+|[0-9]+))*\'*', 'g')
const str = `m
a_4
in23_left
a1b2_3'
camelCase
x''`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}