import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*<p>\\s*(?:</?\\w+/?>\\s*)*<a href=\\\"(?:(?:[a-z]+:)?//(?:[^\\\" >/.]*\\.)*(?:youtube\\.com|youtu\\.be)[/\\\"])\\W*(?![\\W\\w]*?</(?:code|blockquote)>)(?#Separate start with youtube watch; lower TP rate, but most TP are not otherwise detected)";
final String string = "<p><a href=\"https://youtu.be/GuF_h5NfrOw\" rel=\"nofollow noreferrer\">This YouTube video describes the process to add spaces between icons in the DOCK ribbon on your Mac OS Big Sur, Mojave, ... 🍽📏</a></p>\n\n"
+ "<p><a href=\"https://www.youtube.com/watch?v=SnPsJM1qCVk\" rel=\"nofollow noreferrer\">https://www.youtube.com/watch?v=SnPsJM1qCVk</a>\n"
+ "<a href=\"https://www.youtube.com/watch?v=SnPsJM1qCVk&feature=youtu.be\" rel=\"nofollow noreferrer\">https://www.youtube.com/watch?v=SnPsJM1qCVk&feature=youtu.be</a></p>\n"
+ "<p>wa365bet situs slot terbaik terbesar dan terpercaya</p>\n\n"
+ "<p><a href=\"https://www.youtube.com/watch?v=9jK-NcRmVcw\" rel=\"nofollow noreferrer\">https://www.youtube.com/watch?v=9jK-NcRmVcw</a></p>\n"
+ "<p>look at this, this will help you</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}