import re
regex = re.compile(r"^\s*<p>\s*(?:</?\w+/?>\s*)*<a href=\"(?:(?:[a-z]+:)?//(?:[^\" >/.]*\.)*(?:youtube\.com|youtu\.be)[/\"])\W*(?![\W\w]*?</(?:code|blockquote)>)(?#Separate start with youtube watch; lower TP rate, but most TP are not otherwise detected)", flags=re.MULTILINE)
test_str = ("<p><a href=\"https://youtu.be/GuF_h5NfrOw\" rel=\"nofollow noreferrer\">This YouTube video describes the process to add spaces between icons in the DOCK ribbon on your Mac OS Big Sur, Mojave, ... 🍽📏</a></p>\n\n"
"<p><a href=\"https://www.youtube.com/watch?v=SnPsJM1qCVk\" rel=\"nofollow noreferrer\">https://www.youtube.com/watch?v=SnPsJM1qCVk</a>\n"
"<a href=\"https://www.youtube.com/watch?v=SnPsJM1qCVk&feature=youtu.be\" rel=\"nofollow noreferrer\">https://www.youtube.com/watch?v=SnPsJM1qCVk&feature=youtu.be</a></p>\n"
"<p>wa365bet situs slot terbaik terbesar dan terpercaya</p>\n\n"
"<p><a href=\"https://www.youtube.com/watch?v=9jK-NcRmVcw\" rel=\"nofollow noreferrer\">https://www.youtube.com/watch?v=9jK-NcRmVcw</a></p>\n"
"<p>look at this, this will help you</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")