const regex = new RegExp('^\\s*<p>\\s*(?:</?\\w+/?>\\s*)*<a href=\\"(?:(?:[a-z]+:)?//(?:[^\\" >/.]*\\.)*(?:youtube\\.com|youtu\\.be)[/\\"])\\W*(?![\\W\\w]*?</(?:code|blockquote)>)(?#Separate start with youtube watch; lower TP rate, but most TP are not otherwise detected)', 'gm')
const str = `<p><a href="https://youtu.be/GuF_h5NfrOw" rel="nofollow noreferrer">This YouTube video describes the process to add spaces between icons in the DOCK ribbon on your Mac OS Big Sur, Mojave, ... 🍽📏</a></p>
<p><a href="https://www.youtube.com/watch?v=SnPsJM1qCVk" rel="nofollow noreferrer">https://www.youtube.com/watch?v=SnPsJM1qCVk</a>
<a href="https://www.youtube.com/watch?v=SnPsJM1qCVk&feature=youtu.be" rel="nofollow noreferrer">https://www.youtube.com/watch?v=SnPsJM1qCVk&feature=youtu.be</a></p>
<p>wa365bet situs slot terbaik terbesar dan terpercaya</p>
<p><a href="https://www.youtube.com/watch?v=9jK-NcRmVcw" rel="nofollow noreferrer">https://www.youtube.com/watch?v=9jK-NcRmVcw</a></p>
<p>look at this, this will help you</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}