import Foundation
let pattern = ##"^\s*<p>\s*(?:</?\w+/?>\s*)*<a href=\"(?:(?:[a-z]+:)?//(?:[^\" >/.]*\.)*(?:youtube\.com|youtu\.be)[/\"])\W*(?![\W\w]*?</(?:code|blockquote)>)(?#Separate start with youtube watch; lower TP rate, but most TP are not otherwise detected)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p><a href="https://youtu.be/GuF_h5NfrOw" rel="nofollow noreferrer">This YouTube video describes the process to add spaces between icons in the DOCK ribbon on your Mac OS Big Sur, Mojave, ... 🍽📏</a></p>
<p><a href="https://www.youtube.com/watch?v=SnPsJM1qCVk" rel="nofollow noreferrer">https://www.youtube.com/watch?v=SnPsJM1qCVk</a>
<a href="https://www.youtube.com/watch?v=SnPsJM1qCVk&feature=youtu.be" rel="nofollow noreferrer">https://www.youtube.com/watch?v=SnPsJM1qCVk&feature=youtu.be</a></p>
<p>wa365bet situs slot terbaik terbesar dan terpercaya</p>
<p><a href="https://www.youtube.com/watch?v=9jK-NcRmVcw" rel="nofollow noreferrer">https://www.youtube.com/watch?v=9jK-NcRmVcw</a></p>
<p>look at this, this will help you</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)