#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)ENUM(.*?)ENDENUM"
Local $sString = "ENUM CMF_QUOTE_EVENT" & @CRLF & _
" CMF_QUOTE_EVENT_Activate "Activate"" & @CRLF & _
" CMF_QUOTE_EVENT_Suspend "Suspend"" & @CRLF & _
" CMF_QUOTE_EVENT_Delete "Delete"" & @CRLF & _
"ENDENUM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")