re = /ENUM(.*?)ENDENUM/
str = 'ENUM CMF_QUOTE_EVENT
CMF_QUOTE_EVENT_Activate "Activate"
CMF_QUOTE_EVENT_Suspend "Suspend"
CMF_QUOTE_EVENT_Delete "Delete"
ENDENUM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end