import re
regex = re.compile(r"ENUM(.*?)ENDENUM", flags=re.DOTALL)
test_str = ("ENUM CMF_QUOTE_EVENT\n"
" CMF_QUOTE_EVENT_Activate \"Activate\"\n"
" CMF_QUOTE_EVENT_Suspend \"Suspend\"\n"
" CMF_QUOTE_EVENT_Delete \"Delete\"\n"
"ENDENUM")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")