using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ENUM(.*?)ENDENUM";
string input = @"ENUM CMF_QUOTE_EVENT
CMF_QUOTE_EVENT_Activate ""Activate""
CMF_QUOTE_EVENT_Suspend ""Suspend""
CMF_QUOTE_EVENT_Delete ""Delete""
ENDENUM";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}