import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<br \\/>([\\w-]+):\\s*(.+)";
final String string = "<br />admin-c: AFM3\n"
+ "<br />tech-c: AFM3\n"
+ "<br />billing-c: AFM3\n"
+ "<br />nserver: ns1.locaweb.com.br\n"
+ "<br />nsstat: 20190304 TIMEOUT\n"
+ "<br />nslastaa: 20190301\n"
+ "<br />nserver: ns2.locaweb.com.br\n"
+ "<br />nsstat: 20190304 AA\n"
+ "<br />nslastaa: 20190304";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}