using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/(?:(?:[\w\d-]\/?)*[A-Za-z0-9])$";
string input = @"/path
/valid/path
/this/regex/uses/A-Za-z0-9-_/and/should/end/with/A-Za-z0-9
invalid/path
another/invalid/path/
/this/is/also/invalid/
/whoops//ies
//not/even/a/valid/path";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}