const regex = /^\/(?:(?:[\w\d-]\/?)*[A-Za-z0-9])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/(?:(?:[\\w\\d-]\\\/?)*[A-Za-z0-9])$', 'gm')
const str = `/path
/valid/path
/this/regex/uses/A-Za-z0-9-_/and/should/end/with/A-Za-z0-9
invalid/path
another/invalid/path/
/this/is/also/invalid/
/whoops//ies
//not/even/a/valid/path`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}