import Foundation
let pattern = #"^\/(?:(?:[\w\d-]\/?)*[A-Za-z0-9])$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/path
/valid/path
/this/regex/uses/A-Za-z0-9-_/and/should/end/with/A-Za-z0-9
invalid/path
another/invalid/path/
/this/is/also/invalid/
/whoops//ies
//not/even/a/valid/path
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)