using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"blue.{0,10}dog(?!.{0,10}sleeping)";
string input = @"this is a blue dog
this is a blue red dog
this is a blue dog sleeping
this is a blue red dog sleeping
this is a blue red dog red sleeping";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}