re = /blue.{0,10}dog(?!.{0,10}sleeping)/m
str = 'this is a blue dog
this is a blue red dog
this is a blue dog sleeping
this is a blue red dog sleeping
this is a blue red dog red sleeping'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end