$re = '/blue.{0,10}dog(?!.{0,10}sleeping)/m';
$str = 'this is a blue dog
this is a blue red dog
this is a blue dog sleeping
this is a blue red dog sleeping
this is a blue red dog red sleeping';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);