const regex = /blue.{0,10}dog(?!.{0,10}sleeping)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('blue.{0,10}dog(?!.{0,10}sleeping)', 'gm')
const str = `this is a blue dog
this is a blue red dog
this is a blue dog sleeping
this is a blue red dog sleeping
this is a blue red dog red sleeping`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}