using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div [^>]+>([^<]+)<\/div>";
string input = @"<div class=""1"">Получить</div>Пропустить всё<div class=""2"">Получить</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}