re = /<div [^>]+>([^<]+)<\/div>/
str = '<div class="1">Получить</div>Пропустить всё<div class="2">Получить</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end