$re = '/<div [^>]+>([^<]+)<\/div>/';
$str = '<div class="1">Получить</div>Пропустить всё<div class="2">Получить</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);